Android 1.0 and Up